Citrix Content Collaboration experiencing issues in US region
Incident Report for Citrix ShareFile® Status Page
Resolved
Citrix Engineering has mitigated the issue and considers the issue resolved.
Posted Mar 29, 2022 - 15:21 EDT
Monitoring
Citrix Engineering has mitigated the issue and continues to monitor closely.
Posted Mar 29, 2022 - 15:12 EDT
Investigating
Citrix Content Collaboration experiencing issues in US region that would impact end users. Impacted customers may encountered issues accessing or using Citrix ShareFile.
Posted Mar 29, 2022 - 15:04 EDT
This incident affected: ShareFile®.