Citrix Content Collaboration may be experiencing issues...
Incident Report for Citrix ShareFile® Status Page
Resolved
At this time, we believe that the issues affecting Citrix Content Collaboration service customers have been fully resolved.

If any further issues are seen, please contact Citrix Technical Support.
Posted Feb 18, 2021 - 13:34 EST
Identified
Decryption in the email function is down on all accounts leveraging non-US based storage zones. Customers are able to send, but not decrypt emails.

Citrix Engineering teams are investigating the issue.

Another update will be provided within the next 60 minutes.
Posted Feb 18, 2021 - 12:47 EST
This incident affected: ShareFile®.