Citrix Content Collaboration (ShareFile) encountering delays with E-mail notifications.
Incident Report for Citrix ShareFile® Status Page
Resolved
Current Status:
At this time, we believe that the issues affecting Citrix ShareFile E-mail notifications have been resolved.

Next Steps:
If any further issues are seen, please contact Citrix Technical Support. We will continue to monitor closely.
Posted Mar 12, 2021 - 17:21 EST
Monitoring
Current Status:
Citrix Engineering has completed mitigation activities and currently monitoring for E-mail notifications returning to normal operations.

Next Steps:
An update will be provided in no later than 60 minutes.
Posted Mar 12, 2021 - 16:10 EST
Identified
Current Status:
Citrix Engineering has identified the issue and working on mitigations.

Next Steps:
Another update will be provided within the next 60 minutes.
Posted Mar 12, 2021 - 15:27 EST
Update
Impact:
Citrix Content Collaboration service is currently experiencing issues that would impact customers in the US region (EU region is not impacted after further investigation). Impacted customers are encountering delays in E-mail notifications when using Citrix ShareFile. This delay also impacts our customers' ability to request a password reset.

Current Status:
We are currently investigating the issue. Citrix Engineering team is actively working on mitigation.

Next Steps:
Another update will be provided within the next 60 minutes.
Posted Mar 12, 2021 - 14:26 EST
Investigating
Impact:
Citrix Content Collaboration service is currently experiencing issues that would impact customers across all regions. Impacted customers would have encounter delays in E-mail notifications when using Citrix ShareFile.

Current Status:
We are currently investigating the issue. Citrix Engineering team is actively working on mitigation.

Next Steps:
Another update will be provided within the next 60 minutes.
Posted Mar 12, 2021 - 13:29 EST
This incident affected: ShareFile®.