Users may be experiencing issues with uploads and downloads
Incident Report for ShareFile® Status Page
Resolved
This incident has been resolved. If you are still experiencing any issues, please let us know via support using this link https://support.citrix.com/cscase/ams/sharefile

We apologize for the impact of this issue for your business and are taking steps to reduce the likelihood of this occurring again in the future.
Posted Jul 28, 2024 - 22:56 EDT
Investigating
ShareFile customers may be experiencing issues with uploads and downloads We are investigating this issue and we will provide updates here as soon as possible.
Posted Jul 28, 2024 - 22:34 EDT
This incident affected: ShareFile®.