Citrix ShareFile may be experiencing issues
Incident Report for Citrix ShareFile® Status Page
Resolved
At this time, we believe that the issues impacting performance for a small subset of end users in the US region have been fully resolved. If any further issues are seen, please contact Citrix Technical Support.
Posted Jan 15, 2021 - 11:10 EST
Monitoring
A fix has been implemented and currently the team is monitoring the systems to ensure full restoration of normal operations has been achieved.
Posted Jan 15, 2021 - 11:01 EST
Investigating
Citrix ShareFile is currently experiencing latency issues that would impact a small subset of end users in the US region.

We have identified the issue and are currently working on implementing and rolling out a fix.

Another update will be provided after the fix has been implemented, within the next 30 minutes.
Posted Jan 15, 2021 - 10:46 EST
This incident affected: ShareFile®.