ShareFile is currently unavailable
Incident Report for ShareFile® Status Page
Postmortem

ShareFile Service Event – October 19, 2023

Summary of Impact

On October 19, 2023, ShareFile users were unable to access the application for 43 minutes. The incident started on October 19, 2023 at 11:34 AM EST and was mitigated at 12:17PM EST. The incident was caused by a code change intended for non-production environments that impacted ShareFile production environment. The incident was mitigated by ShareFile engineering teams when the specific change and cause was identified and rolled back.

Cause & Mitigation

The incident was caused by a code change intended to clean up legacy resources in ShareFile non-production environments, which impacted the production environment causing the ShareFile application to be unavailable. The incident was mitigated by ShareFile engineering teams when the specific cause was identified and rolled back. The code change was reverted and legacy resources affected were recreated by an active canary roll-out, which resolved the incident.

Next Steps & Retrospective

ShareFile engineering teams will implement additional guardrails to help prevent this issue from occurring in the future:

· Developing an updated risk matrix to better identify risk of production changes and an improved process for review, in both non-production and production environments.

Our Commitment to Service, Reliability, and Performance

ShareFile teams are continuously taking steps to prevent and mitigate future incidents. ShareFile engineering teams are actively investing in architectural and operational items focused on high availability and service resiliency.

As a reminder, https://status.sharefile.com/ is where all outages and impacts to ShareFile are communicated broadly to customers. Please reach out to ShareFile Technical Support if you have any further questions.

Posted Oct 23, 2023 - 13:59 EDT

Resolved
This incident has been resolved.
Posted Oct 19, 2023 - 12:34 EDT
Update
We are continuing to monitor for any further issues.
Posted Oct 19, 2023 - 12:25 EDT
Update
We are continuing to monitor for any further issues.
Posted Oct 19, 2023 - 12:24 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 19, 2023 - 12:18 EDT
Update
ShareFile is now functional for US; monitoring is ongoing. A fix is currently being implemented for EU.
Posted Oct 19, 2023 - 12:16 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 19, 2023 - 12:11 EDT
Investigating
We are currently investigating this issue.
Posted Oct 19, 2023 - 11:45 EDT
This incident affected: ShareFile®.