Some ShareFile customers may be experiencing issues with their ShareFile account

Incident Report for ShareFile® Status Page

Resolved

This incident has been resolved.
Posted Sep 21, 2026 - 22:45 EDT

Investigating

Some ShareFile customers may be experiencing issues with their accounts. We are investigating this issue and we will provide updates here as soon as available.
Posted Sep 21, 2026 - 17:45 EDT
This incident affected: ShareFile®.