Sharefile system issues
Incident Report for Citrix ShareFile® Status Page
Resolved
This incident has been resolved.
Posted Jun 30, 2022 - 11:58 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 30, 2022 - 11:53 EDT
Update
We are continuing to investigate this issue.
Posted Jun 30, 2022 - 11:09 EDT
Investigating
Citrix Content Collaboration(Sharefile) service is currently experiencing issues in US that would impact end-users & admins. End-users & admins impacted are unable to use the service.

A further update will be issued within 60 minutes (16:00 UTC)
Posted Jun 30, 2022 - 11:03 EDT
This incident affected: ShareFile®.