Some ShareFile customers may be experiencing issues with their ShareFile account

Incident Report for ShareFile® Status Page

Resolved

This incident has been resolved.
Posted Jul 10, 2025 - 19:06 EDT

Update

We are continuing to investigate. The issue appears to be limited to email notification delivery
Posted Jul 10, 2025 - 15:52 EDT

Investigating

Some ShareFile customers may be experiencing issues with their accounts. We are investigating this issue and we will provide updates here as soon as available.
Posted Jul 10, 2025 - 15:34 EDT