Citrix ShareFile customers may be experiencing issues...
Incident Report for Citrix ShareFile® Status Page
Resolved
At this time, we believe that the issues affecting the Citrix ShareFile service have been fully resolved. We will continue to monitor closely.

If any further issues are seen, please contact Citrix Technical Support.
Posted Feb 17, 2022 - 13:03 EST
Monitoring
Current Status: At this time, we believe that the issues affecting the Citrix ShareFile service have been mitigated. We will continue to monitor closely.



Next Steps: If any further issues are seen, please contact Citrix Technical Support.
Posted Feb 17, 2022 - 12:54 EST
Investigating
Citrix ShareFile service is experiencing issues in the US region leading to admins and end users inability to access or load ShareFile.

Citrix Engineering is currently investigating the issue.

A further update will be provided within 60 minutes.
Posted Feb 17, 2022 - 12:11 EST
This incident affected: ShareFile®.